Runners Forum - Kick Runners banner

1 - 20 of 22 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter · #1 ·
Hey Guys/Gals:<br><br>
I need your help, please!<br><br>
I'm in the 'test' mode for moving the login screen to the main page and OFF the forum. <i>I just posted information on this in our Kickrunners News Link on the main page</i>.<br><br>
This only effects: <b>Power Turk Blue</b> Template - Recall the earlier poll about who uses what template? No one who replied used this template, so it's my 'test' template.<br><br>
Here's where you come in:<br><br>
I would like you to change your template to Power Turk Blue for a while. Maybe a week or so.<br><br>
Here's the steps I need you to do:<br><br>
1. Logged in - go to the bottom of the forum and change your default template to <b>Power Turk Blue<br></b>2. Click on the Logo at the TOP of the Forum to take you to the Main page and LOG OUT there.<br>
3. While logged out, click on the forum link and confirm you can't log in at the forum.<br>
4. go back to the main page and log in and then proceed to the forum and confirm you're logged in.<br><br><br>
Use the site as normal and post your comments, issues, problems, etc... in this thread.<br><br>
If any users ask you what's going on (As in there are users using this template) - please point them to the main page and read the Kickrunners News entry.<br><br><br>
Thanks for helping.. and this, by the way, is why you make the <b>BIG BUCKS!!!<br><br><br></b>Best,<br><br><br>
Rich
 

·
Premium Member
Joined
·
3,523 Posts
Ok, I logged out of the forum page first, thats what I screwed up. Now its working right, (If I ONLY knew how to follow directions <img alt="rolleyes.gif" src="http://files.kickrunners.com/smilies/rolleyes.gif"> )<br><br>
When I am logged in from the front page, it does give my the fugly colors and there is no login on the forum page.
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #3 ·
Nope - you're testing!!!<br><br>
I just removed the log out option from the forum...<br><br>
I just haven't set the 'non registered' to 'Power Turk Blue" and that's probably why
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #4 ·
I THINK this will work. I'm not going to push the 'default' to Power turk blue, because the bulk of our users use the Default setting now and that would freak them ALL out!<br><br>
So, just make sure you can still do everything else.<br><br>
Things to try:<br><br>
Log in and then leave the site without closing your browser. Return to the main page and go to the forum. Are you still logged in? Front page/forum page?<br><br>
Log in and then close your browser - and repeat above...<br><br>
In essence - see if you can create circumstances where you are logged in at the main page but NOT logged in in the forum... (which I'm sure will happen - but let's figure it out!)<br><br><br>
Thanks!<br><br><i>oh, and welcome to WTF UNIVERSITY!!!<br><img alt="surprised.gif" src="http://files.kickrunners.com/smilies/surprised.gif">ccasion5:</i>
 

·
Premium Member
Joined
·
3,523 Posts
ok, browser open, leave site, come back, still logged in with fugly colors on the forum page, but not the front page.<br><br>
close browser, have to log in, to get fugly colors again.<br><br>
ok, that time, I left the site, it logged me out, when I came back and logged in, I was back to default colors, it didnt save the fugly colors that I had had before! (Maybe its reading my mind??? <img alt="wink.gif" src="http://files.kickrunners.com/smilies/wink.gif"> )
 

·
Registered
Joined
·
9,714 Posts
Interesting. It went from PTBlue to Default back to my lovely fancygrey as I logged out and back in (in the forum).
 

·
Premium Member
Joined
·
5,027 Posts
OK. I will do this when I'm not so sleepy and can follow directions.<br><br>
I like that this site is always changing and improving. <img alt="smile.gif" src="http://files.kickrunners.com/smilies/smile.gif">
 

·
Registered
Joined
·
344 Posts
I kind of like this style better, althought the multiquote button image is not show up for me. The text is there, but no image, the other's are there<br><br>
also the add infraction button show's up as text only, no image
 

·
Registered
Joined
·
6,892 Posts
Good morning Rich. I finally had time to do a little Q/A. Btw, at one of the company's I work with, I have the dubious title of being 'Best Software Breaker'. <img alt="sign12.gif" src="http://files.kickrunners.com/smilies/sign12.gif"><br><br>
A little info in case it's helpful: I was using fancygrey on a Safari browser when I started, and had the front page set to auto-login. I also had the forums set on my bookmark, so while I did cruise the front page, my m.o. was to use a bookmark straight into the forums, already logged in (I had autocomplete set up so I didn't have to put in username password, w/ the checkbox to keep me logged in.)<br><br>
I tried setting my color scheme to the loud blue one as requested, then went to the home page to log out. I found no 'logout' button, and discovered I was still logged in.<br><br>
I came back to your instructions here, and found a 'logout' button at the bottom of this board's page, where I shouldn't have. But with no button on the Front Page, I clicked this logout button. And not only did it log me out, it gave me a message about clearing the cache. So then I knew the reason why my first pass didn't work is b/c the screens were cached.<br><br>
I went back to the Front page, now logged out, and tried to click into the forums. They were all locked to me.<br><br>
I went back to the Front page and logged in, found myself still in the Loud Blue theme (sorry, can't remember the name of this theme) and was able to post. And no 'logout' button in the forums.<br><br>
I went back to the Front page and clicked 'logout' again from the home page this time, back into the forums and again locked to me.<br><br>
I went back to the Front page, logged in, still Loud Blue. I left the window (using tabbed windows in Safari) to go to another website in another window, interacted there, then came back to the PRT and posted a reply to a thread there with no problem. Still logged in.<br><br>
I went back to the Front page, logged out again. Then logged back in, back to PRT to confirm I was still logged in. Then closed the window completely. When I relaunched kickrunners.com (not using bookmark directly to forums) I was not logged in, so I logged in, back to the PRT, and still logged in.
 

·
Registered
Joined
·
6,892 Posts
Next test:<br>
I went back to the Front page and logged out. I closed the browser. Opened a new browser, typed in the URL to take me to Kickrunner's Front page, where I was still logged out (prompt to login vs. logout button). I clicked into the forums, into VRAA, and confirmed that I was logged out and threads locked to me.<br><br>
Next I closed the browser, opened a new browser and clicked on my bookmark that takes me straight to the forums. When I did this, my account was logged in, although I didn't log in on the front page. And I was able to post. So using the <a href="http://www.kickrunners.com/forum" target="_blank">www.kickrunners.com/forum</a> bookmark allowed me to bypass the Front page login step altogether.<br><br>
I closed that browser. Opened a new browser and used the bookmark again just to verify that I'd get the same behavior a second time, and I did. I was logged in at the forums again, and am now typing this post without having logged in at the front page.
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #12 ·
Now THAT's what I call TESTING!!! <img alt="smile.gif" src="http://files.kickrunners.com/smilies/smile.gif"><br><br>
Could you 'translate' it for me? <img alt="biggrin.gif" src="http://files.kickrunners.com/smilies/biggrin.gif"><br><br>
Are you telling me it doesn't work on Safari? or it does? Or it kinda does?<br><br>
Thanks for putting up with th 'yucky blue'.. (feel free to go back to yoru normal template - but on occasion try it the login feature again...<br><br><br>
Thanks!<br><br><br>
 

·
Registered
Joined
·
6,892 Posts
Next test:<br>
Directly after posting here from an auto-logged in fashion, I went back to the Front page, that showed that I WAS NOT logged in. I clicked into the forums and they were all locked.<br><br>
Conclusion: if a member uses a bookmark directly to the forums, they will be unlocked and the member will be auto-logged in. However, upon returning to the Front page, the site will then recognize that this member had not logged in, and treat them as a non-logged in member, with the option there to log in.
 

·
Registered
Joined
·
6,892 Posts
Ha! <img alt="biggrin.gif" src="http://files.kickrunners.com/smilies/biggrin.gif"> I would MUCH rather be testing for you than doing my expense reports!<br><br>
Translation:<br>
if the expected behavior is to require users to go to the Front page and login everytime, then stay logged in no matter what they do, this seems to work perfectly on a Mac OS-X with Safari browser. (I'm going to do some tests now w/ links off the home page. Do you think you could enable the chat feature for a little while so I can see if it impacts the login?)<br><br>
However, using a bookmark set up to take me directly to the forums allows me to get to them without EVER having to log in, or go to the Front Page. If you want people to go to the Front Page every time, then this is a way for them to cheat that. Which I'm not sure is a bad thing; advanced computer users are used to using bookmarks for efficiency. But it does allow them to avoid the Front Page.
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #15 ·
I actually pulled the chat engine and am currently looking for another.<br><br>
On the bookmark thing - I'm ok with that; however, as the running log comes about - you will only be able to access it from the main page and to that extent, at least they'll go to the front page to access their logs.<br><br>
I think if I 'forced' the login to the main page now, it would work 'OK' - but I don't feel 100% confident yet and don't want to LOSE members because of it...<br><br>
So, keep kickin' the tires and we'll figure it out!<br><br><br>
Thanks
 

·
Registered
Joined
·
6,892 Posts
Gotcha.<br><br>
A little more tire kicking confirmed that there's nothing I can click in off the front page when NOT logged in that will allow me to interact with the forums, b/c all of those links either open new windows, or are embedded in the framework of the front page, so I see the login on the left at all times.
 

·
Registered
Joined
·
6,892 Posts
Two more tests:<br>
The opposite of the previous post:<br>
I logged in, then played with all of the features on the Front page. No matter what I clicked on, I remaind logged in and could still access and interact with the forums. This is good.<br><br>
Next I logged out, then closed the browser. I then opened a new browser, and typed in kickrunners.com to go directly to the Front Page. I saw the login prompt, which should mean that I was not logged in. But I clicked on the Forum link, and it behaved as though I WAS logged in. I'm now typing this post from that standpoint.<br><br>
Bottom line, Rich: In all of the tests I ran, there were many times that I should have been logged out, but the site still let me function as though I was logged in.<br><br>
OTOH, there was NO instance where it logged me out unexpectedly. I think that's what you've been worried about, and having us test for, right?<br><br>
I'm very happy that you don't want to exclude people from bookmarking. The log sounds like the perfect vehicle to drive us to the Front Page. That's perfect. I love the philosophy here.
 

·
Registered
Joined
·
6,892 Posts
Another test:<br>
switched back to Turk Power Blue (now I remember the name), went to Front page, logged out.<br>
Closed the browser. Opened a new browser, put in URL for Front Page. As before, although I didn't log in, when I clicked on the Forums, it behaved as though I were logged in; no locked forums.<br>
I went into the "handheld waterbottle" thread in the PRT, and appeared to be logged in. Next I clicked on the link to another KR thread in my reply, which opened up a new browser window with a The Expo thread. And I still appeared logged in there.<br><br>
So another case where the site is letting me work as though I'm logged in, and not kicking me out when I access something else.
 

·
Premium Member
Joined
·
3,523 Posts
Diablita, Thats some amazing detail!<br><br>
Color me impressed! <img alt="biggrin.gif" src="http://files.kickrunners.com/smilies/biggrin.gif">
 

·
Registered
Joined
·
344 Posts
Everytime I close my browser, and enter the site, I have the bookmark set to go to the main page, I have to log in, where before, I was always logged in.
 
1 - 20 of 22 Posts
Top